GHOST: glibc: buffer overflow

0 Flares 0 Flares ×

Una grave vulnerabilidad bautizada como GHOST en GNU/Linux está presente en todas las versiones de Red Hat Enterprise Linux y variantes (CentOS etc.), así como los sistemas Debian.

Listado de distribuciones afectadas:
RHEL(Red Hat Enterprise Linux) version 6.x and 7.x
CentOS Linux version 6.x & 7.x
Ubuntu Linux version 10.04, 12.04 LTS
Debian Linux version 7.x
Linux Mint version 13.0
SUSE Linux Enterprise 11 and older (also OpenSuse Linux 11 or older versions).
Arch Linux glibc version <= 2.18-1

Todos los usuarios de glibc se les recomienda actualizar a estos paquetes

Como saber cual de mis servicios son afectados?

# lsof | grep libc | awk ‘{print $1}’ | sort | uniq

¿Cómo saber si estoy vulnerable?

Crear este archivo ghost.c

COMPILAMOS

# gcc ghost.c -o ghost

VERIFICAMOS
#./ghost

Como corregir?

# yum update glibc

Y reinicia todos los servicios que usan esa librería

¿Te gustaría escribir en este blog?
1. Debes dedicarte a la tecnología y debes escribir cosas bien interesantes
2. Debes patrocinarnos para publicar esos contenidos y obtener el banner inferior de patrocinador. Recuerda que entre major valorado sean tus contenidos, mayor visibilidad de tu banner.

Alfanux
VCP - MCSA - MCTS - RHCSA - RHCE - RHCVA





Related News

Leave a Reply

Your email address will not be published. Required fields are marked as *

*

0 Flares Facebook 0 LinkedIn 0 Google+ 0 Twitter 0 0 Flares ×